Forum Navigation
Please or Register to create posts and topics.

Fallo entre MKR shield Y Extensión I2C IO

Hola a todos os explico un poco el fallo que tengo, tengo montada una MKR shield y una I2C IO todo aparentemente funciona bien y cada 2 ó 3  dias las salidas de la placa I2C IO dejan de funcionar les mandas las ordenes y no cambian de estado si aflojo uno de los  tornillos de comunicación entre las placas ( SCL o SDA) vuelve a funcionar y ya hay comunicación hasta que vuelve a fallar, he cambia los cables, comprobado soldaduras, repasado el programa pero no se que puede ser ¿? Alguien le ha pasado esto ¿?.

Gracias a todos.

Puedes subir unas fotos de la instalación?

Hola Roberto, te paso la foto esta en modo prueba hasta que todo funcione correctamente y pasa a la instalación definitiva, me gusta probarlo antes, he vuelto a cambiar el cable de unión SCL /SDA.

Gracias.

 

Uploaded files:
  • Foto.jpg

La única causa posible de ese comportamiento es una alimentación inestable sobre la i2c io... Tienes q céntrate en eso, el bus y demás lo puedes descartar al 100%... Busca una caída de tensión en algún punto una caída brusca, lo q es un pico..puedes probar otra fuente?

Si Roberto tengo otra fuente la cambio hoy mismo y lo pruebo unos días, os voy comentando.

Gracias.

Buenos días, después de casi una semana desde que se cambio la fuente de alimentación no ha vuelto a perder la comunicación entre las placas y funciona correctamente, ahora a pensar en actualizar la instalación de Mega a Mkr y aprovechar para realizar algún cambio.

Gracias Roberto.