Forum Navigation
You need to log in to create posts and topics.

Importante actualización notificaciones PUSH con servidor.... Update to firebase

Perdona Roberto que insista. El botón que aparece a la izq. es para "Añadir Nuevo" como dice el desplegable que aparece al posicionar el puntero del ratón.

De hecho al pulsar en él me sale un error que, entiendo, que te indica "Indice fuera de los límites de la matriz" y es verdad que este arduino sólo tiene 2 circuitos y por lo tanto no puedo añadir más.

Alguien más podría probarlo en su server ???

Uploaded files:
  • EnabledHorarios-AñadirNuevo.png
  • EnabledHorarios-Error.png

Hola...

Que va... el boton es guardar... ademas no se pueden añadir elementos dinamicamente... se declaran mediante el archivo ins.

El texto del botón si que se tiene que cambiar... pero eso es algo que puede hacer cualquiera... corresponde a diseño que es algo totalmente modificable....después de todo siempre he tenido la ilusión de que la web tuviera varios temas de diseño. y esta hecha para que eso no sea difícil.... con conocimientos medios de css y html se puede hacer un tema nuevo.

En cuanto a lo de guardar, yo lo puedo hacer sin ningún inconveniente.... Tal vez tengas algún error en el archivo inst.... lo que si se es que si me conecto a tu instalacion en 10 minutos lo veo.

Te adjunto un video rápido donde ves como cambiar el boton y como lo guardo  sin problemas.

Si ves que tienes problemas nos tomamos una cerveza online y lo vemos mientras me cuentas que tal todo 😉

Estado = Overload.

OK Roberto. Esta tarde lo compruebo.

Muchas gracias por todo.

Hola a todos:

 

Ya he compilado la web app y efectivamente se nota la mejora en rapidez Roberto, sin embargo sigo con el problema de la actualizacion del servicio y exserver, por lo que puedo observar a través de exserver, me sale continuamente cliente conectado y cliente desconectado (cada 4-5 segundos), he ido desconectando elementos que controlo por mkrmqtt y no tiene nada que ver... (la situación es muy extraña, con la versión exserver 6.0.0.2 y servicio 4.00.001 todo va bien... si actualizo a exserver 6.0.0.3 y servicio 4.30.001 deja de  funcionar... desinstalo y vuelvo a instalar la versión antigua y todo funciona perfectamente)

Por lo que entiendo los topics de mkrmqtt se crean en el ide de mkrmqtt por tanto no hay que tocar ni antes ni ahora el fichero mqtt.xml, no?

... a alguien se le ocurre que puede ser?

He he hecho un vídeo del megamqtt funcionando con esta versión... Todo perfecto.

Mañana lo subo para q lo veas a ver si ves algo diferente a lo q haces.

 

Por curiosidad...configuras la IP del de tu servidor correctamente en tu Server?

Una ayuda para identificar tu problema sería ver el debug Mode cuando se pierde la conexión con el servidor mqtt

Estado = Overload.

Esta acabando de subirse... en unos minutos ya sale.

 

Estado = Overload.

Muchas gracias por el video Roberto,

 

a falta de confirmarlo (espero que sea por eso), la única diferencia que he encontrado, es que la versión del IDE de arduino que estás usando es la 1.8.9 y yo tengo la 1.8.7, por todo lo demás no hay deferencia, piensa que ahora mismo me funciona todo perfectamente (pero eso si, con las versiones anteriores del exserver y servicio), así que me huele que va a ser eso... ya informo.

Efectivamente, algo raro ocurre... te digo los cambios que he hecho y con ello todo ok durante estas 5 horas.

Vale... he comprobado con mkr1000.... y por fin lo he visto... antes no podia  , estaba de viaje y solo tenia mega... en mi instalación uso mega mqtt y con ese no ocurría eso.

 

La versión de arduino la ultima (esto ya lo tenia)

Después actualizar la definición de la placa en el software de arduino, adjunto imagen ... versión 1.26.21

Después... también he actualizado la versión del firmware del wifi del arduino.

Y listo... con eso ya lo tengo igual que la versión del mkr... no he necesitado actualizar nada mas... mismo exserver y servicio... todo ok.

Muchas gracias por el reporte manuchu...

Uploaded files:
  • SAM.png
Estado = Overload.

Por si acaso... la libreria mqtt tambien la tengo a la ultima, v2.4.3

https://github.com/256dpi/arduino-mqtt/releases

Estado = Overload.