Forum Navigation
You need to log in to create posts and topics.

Importante actualización notificaciones PUSH con servidor.... Update to firebase

Yo he  montado un mkr y he probado los retroavisos y todo ok....

Prueba a enviar un retroaviso con otro equipo por si acaso, un esclavo mqtt o algo...

Pero vamos yo creo que  ya solo  a no ser que aportes algo menos abstracto solo puedo  ayudarte con presupuesto viendo tu instalación totalmente..... 🙂 🙂

 

Estado = Overload.

Bueno, creo que puedo dar por solucionado el problema, a falta de tenerlo unas cuantas horas para afirmarlo rotundamente, pero por el momento me funcionan sin problemas los retroavisos.

El problema está en que en el mkr tengo un circuito temporizado (que me enciende o apaga una tira de led wifi), el cual se activa a través de un PIR instalado en otra central (recibo la señal a través de un Packet), pues bueno, tenia el circuito que me indicaba si estaba activo o no ese PIR o esa temporización. Ese circuito no está declarado en los topics de global variables zone, porque solo me indica cuando el PIR de la otra central está activo o no, no tiene otro uso. Pues bueno, eliminando ese circuito todo me funciona bien.

Por lo que entiendo no tiene sentido crear un circuito al que no vaya asociado un topic, pero lo que no entiendo es que con una versión del servicio funcione y con otra no.

Espero haberme explicado... en caso contrario me lo indicais y amplio información.

En cualquier caso, agradecerte Roberto la paciencia mostrada.

Me alegro mucho manuch... muchas gracias por confirmar... eso ayuda a tanto a excontrol como a otros usuarios... muchas gracias.

Estado = Overload.

Hola,  con motivo de dejar de recibir las notificaciones he decidido actualizar la nueva app , ExServer y Servicio, además he aprovechado para migrar el Servidor a otro PC. Pues bien he de decir que no lo he conseguido del todo... todo funciona, si tengo abierto Exserver, ya que el servicio aunque se instala aparentemente no funciona en segundo plano. Se sabe, porque al abrir Exserver no hay conflicto en el puerto de comunicaciones y todo funciona, en la pestaña de alarmas se ve como van entrando las alarmas y se reciben en la app, aunque he de decir que solo en la barra de notificaciones, no entran en la app, si la app esta abierta y salgo y entro si que aparecen, si esta en segundo plano solo entran en la barra de notificaciones y aunque se pulse en la notificación no se visualizan en la app.

Pero lo que más me mosquea, es que no se como hacer que funcione el servicio. Antes, con la versión anterior de Servicio aparecían dos servicios: "ExControl Service" y "ExControl Servicio de comunicaciones" ahora solo me aparece ExControl Service y parece que no se ejecuta en segundo plano.

He seguido al pie de la letra el manual, y he visto los videos varias veces, lo único que he de decir es que la versión de  Net 4.5.2 no se instala, por que hay una más actualizada en Windows 10, que es la 4.7, no obstante he actualizado ala 4.8 y tampoco funciona el Sercicio

Alguna sugerencia

Gracias