Forum Navigation
You need to log in to create posts and topics.

Integracion zigbee2mqtt en Excontrol (COLABORATIVO)

En el fichero MQTT y PanX :

####################################    MQTT   ####################################

<?xml version="1.0" encoding="UTF-16"?>

-<Config Port="1884" ip="192.168.2.XX">

<Circuito Value_0="Off" Value_1="On" Topic="zigbee2mqtt/PIR_1/occupancy" Tipo="4" Nombre="Xiaomi PIR_1"/><!--Xiaomi PIR_1-->

<!--Circuito Nombre="Xiaomi PIR_1" Tipo="0" Topic="zigbee2mqtt/PIR_1/occupancy" Value_true="On" Value_false="Off"/><!Xiaomi PIR_1-->

<Sensores Topic="zigbee2mqtt/Temp-Hume_1/temperature" Tipo="4" Nombre="Xiaomi TEMP1" Image="~/Img/s_generico.png"/><!--Xiaomi TEMP-->

<Sensores Topic="zigbee2mqtt/Temp-Hume_1/humidity" Tipo="4" Nombre="Xiaomi HUMEDAD1" Image="~/Img/s_generico.png"/><!--Xiaomi HUMEDAD-->

<Sensores Topic="zigbee2mqtt/Temp-Hume_1/linkquality" Tipo="4" Nombre="Xiaomi linkquality" Image="~/Img/s_generico.png"/><!--Xiaomi linkquality-->

<Sensores Topic="zigbee2mqtt/Temp-Hume_1/battery" Tipo="4" Nombre="Xiaomi battery" Image="~/Img/s_generico.png"/><!--Xiaomi battery-->

<Sensores Topic="zigbee2mqtt/Temp-Hume_1/voltage" Tipo="4" Nombre="Xiaomi voltage" Image="~/Img/s_generico.png"/><!--Xiaomi voltage-->

<Sensores Topic="zigbee2mqtt/PIR_1/linkquality" Tipo="4" Nombre="Xiaomi Pir1_linkquality" Image="~/Img/s_generico.png"/><!--Xiaomi PIR1_linkquality-->

<Sensores Topic="zigbee2mqtt/PIR_1/battery" Tipo="4" Nombre="Xiaomi Pir1_battery" Image="~/Img/s_generico.png"/><!--Xiaomi PIR1_battery-->

<Sensores Topic="zigbee2mqtt/PIR_1/voltage" Tipo="4" Nombre="Xiaomi Pir1_voltage" Image="~/Img/s_generico.png"/><!--Xiaomi PIR1_voltage-->

</Config>

 

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@    PanX   @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

<div style="position: absolute ; left:  10%; top:10%;"><uc1:SensorView runat="server" ID="SensorView" Central="5" Index="0" /> </div> <!--Xiaomi TEMP-->

<div style="position: absolute ; left:  10%; top:20%;"><uc1:SensorView runat="server" ID="SensorView1" Central="5" Index="1" /> </div> <!--Xiaomi HUMEDAD-->

 

Excelente. Tienes sólo sensores? no tienes algún enchufe o ampolleta para probar si puedes prender por mqtt?

Cómo sabes qué Topic debes escribir en el archivo mqtt.xml?

Hola, me quito el sombrero.

Ùna cosita, puedes subir una imagen de exserver cuando escribe los valores? de esta manera puedo ayudar a construir el archivo mqtt.

He visto el del pir... pero si tienes mas mejor..

Pablo y Roberto esto vale para los 2.

He tenido que hacerlo en 2 imágenes por que desaparece el texto del server con las entradas nuevas:

Y este texto aparece pasado un tiempo:

En Server :

19:53 - MQTT MessageReceived zigbee2mqtt/Temp-Hume_1-{"temperature":20.7,"linkquality":47,"humidity":42.55,"battery":86,"voltage":2975}

Y desde zigbee2mqtt;

El PIR

zigbee2mqtt:info 2019-3-22 19:37:43 MQTT publish: topic 'zigbee2mqtt/PIR_1', payload '{"occupancy":false,"linkquality":110,"battery":100,"voltage":3005}'

 

Temperatura y Humedad

zigbee2mqtt:info 2019-3-22 19:53:12 MQTT publish: topic 'zigbee2mqtt/Temp-Hume_1', payload '{"temperature":20.7,"linkquality":47,"humidity":42.55,"battery":86,"voltage":2975}'

 

Uploaded files:
  • 1.png
  • 2.png

Si no lo veis bien hago unos zoom ¡¡¡

Gracias

Mira acabo de pillar al server con los 2 :

 

Uploaded files:
  • 3.png

Bueno, pues lo he visto y necesita un pequeño codigo.

Adjunto un código SIN DEPURAR, que podría valer para ver los valores en la web.

Seguramete ,, con una sesión de teamviewer lo tengamos en un rato, yo creo que va a ser lo mejor.

 

 

 

Uploaded files:

Muchas gracias Roberto.

Haber si saco tiempo, que ando muy liado..... demasiados frentes abiertos... y encima el huerto, que este año con el calor ( apenas a helado ) se me han quemado todas las plantas y tengo que replantar otra vez.

Te doy un tk, en cuanto me ponga con ello.

Ok... Pues lo dicho, posponemos, realmente yo también prefiero dejarlo para más adelante la verdad... De todas formas ya lo tienes crack.