Forum Navigation
Please or Register to create posts and topics.

No detecta 3º extender por extensor (solucionado)

Hola  tengo un problemilla con una extension I2C que esta con un I2C-Extender  al principio iba bien pero cuando empecé hacer pruebas empezaba a comunicarse pero al poco paraba y ahora ya no se comunicas. Tengo el MKR con 2 extensiones y luego en otro lugar 10 m mas o meno la extensión que no me va .Las comprobaciones que he hecho son:

  • Revise cableado x, y , vcc y gnd y esta bien
  • Resistencias colocadas 4k7 colocadas en la extensión I2C
  • He dejado la tarjetas aislada si entradas y salida para que no entrada interferencias
  • Puentes colocados según plano en el plano falta dos tarjetas mas de extensiones
  • He cambiado la MKR y también la tercera extender  e igual
  • En la dos  tarjeta extender tiene los puente colocados

¿que otras pruebas puede hacer ? ¿o que me puede estar escapando?

Un saludo y gracias

Uploaded files:
  • fuente-de-alimentacion.png
  • 1X20.jpg
  • 0x21.jpg
  • 0x22.jpg
  • 0x21-resistencias.jpg

Desde aqui es dificil... esas cosas hay que estar delante.

Yo te puedo recomendar... bus i2c usa cable de red o similar ... no metas esa seccion tan grande.. busca un cable de baja capacitancia... y para eso es mejor pequeño.

No compartas espacio entre bus i2c y cables de reles y tal... el cableado de comunicaciones zona limpia.

Si subes una pantalla de debug igual puedo ver algo... pero yo creo que has jodio el conversor.

Como siempre gracias. El cable que va  entre tarjetas extender es de pares pero lo apoyo en bornas y de hay si que le meto ese cable , eso si va el cable de pares va compartido con otro no reles pero si de alumbrado ya que no tengo otra manera tampoco tengo wifi en el lugar . Mando captura de  debug . ¿Si es del conversor hay forma de solucionarlo o no merece la pena? Un saludo y gracias

Uploaded files:
  • 1.png

Has probado la tarjeta fuera del conversor?

Pero es caso de confirmar la avería del conversor yo no pondría otro nuevo antes de averiguar porque se ha ido .. Estos bichos son duros... No es como un pin al aire del mkr

Muchas gracias después de probar las tarjetas que funcionaban  y darle mil vueltas en un borna de la que tengo montadas  había una cable de comunicación que no estaba haciendo bien contacto.  Un saludo y gracias

Me alegro mucho Ivan...