Forum Navigation
You need to log in to create posts and topics.

Version actual definiciones de placa mkr

Ha salido una nueva versión de  definiciones de las placas arduino para la familia mkr.

Siempre es importante tener esto actualizado, y antes de actualizar un equipo darse una vuelta para ver si existe una nueva definición de la placa asi como las librerías asociadas a esa placa, por ejemplo la WiFi101 para el arduino mkr1000 o wifinina para mkr101.

Hemos detectado que algunos usuarios usan librerías nuevas con definiciones de placas viejas o viceversa, esto no es buena cosa y hay cuando se actualiza lo natural es revisar que tenemos la ultima versión de las dos cosas... no trabajar versiones diferentes dentro de un mismo sistema.

Para tener una referencia clara se abre este hilo , en el cual se informa de las ultimas versiones que aparece.

FECHA 18-06-04

GESTOR DE TARJETAS

Arduino Samd Boards(32bit ARM CORTEX M0)   (mkr1000, mkr1010 y familia mkr en general) v1.8.1

Para actualizar tarjetas, desde el ide arduino, MENU herramientas, placa , gestor de tarjetas

 

 

Uploaded files:
  • TARJETAS.png
Estado = Overload.

Muchas gracias Roberto.

Genial y gracias por la info

Gracias Roberto por informar!!

Gracias...

gracias. He hecho una actualización total ,he vuelto a instala arduiono 1.6. 7  he instalado todas las actualizaciones de la biblioteca y la tarjetas como dices.Y al recopilar trabajo me sale:

Arduino:1.6.7 (Windows 10), Placa:"Arduino/Genuino MKR1000"

 

In file included from sketch\PRUEBASSANXENXO.ino.cpp:1:0:

 

C:\Users\Portatil samsumg\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.8.3\cores\arduino/Arduino.h:48:10: fatal error: sam.h: No such file or directory

 

#include "sam.h"

 

^~~~~~~

 

compilation terminated.

 

exit status 1

Error de compilación

 

Este informe podría tener más información con

"Mostrar salida detallada durante la compilación"

activala desde Archivo > Preferencias

¿que puede ser?

Parece q la definición de la placa no se ha cargado bien

 

Creo q deberías actualizar a la última versión del IDE. 1.8.9... esa q usas es muy vieja, seguramente así lo configures más fácil y tienes el IDE con todas las mejoras

Estado = Overload.

Gracias me baje la ultima versión y actualice la biblioteca wifi101 y ya me va.

Un saludo